1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Airplay iOS 11.4 Droidbox T8-S Plus V2 Not Working

Discussion in 'General Discussion' started by ajph1970, Jun 9, 2018.

  1. ajph1970

    ajph1970 New Member

    Hi,

    I am struggling to get any of my iOS devices to screen mirror over to my Droidbox T8-S Plus V2. I have had my Droidbox for a year now and have been having problems with Airplay mirroring only since iOS 11.3 released a couple of months ago. Prior to this everything worked absolutely fine. I have seen various threads on the forums, most of which are now quite old, advising to carry out various things to get it working, all of which I have tried, but to no avail.

    So far I have made sure my iOS devices are all up to date, and that the Airplay app which comes pre-installed on the Droidbox is also up to date. I have tried restarting both my iPad and iPhone and have reset the Droidbox also. I have also tried resetting my router. All of my devices are connected through the same WiFi network in my home and are all connected at the same time. I can use the Droidbox share app on iPad and iPhone to connect to the Droidbox and can control the Droidbox using remote function etc through that app. However, I want to be able to screen mirror as I have a number of apps which I used to connect through screen mirroring, such as yoga apps which I want to see on my smart tv. When I try to screen mirror the iOS devices all see the Droidbox in screen mirroring on the control centre, but unfortunately all that happens is the screen goes blank on the TV and the tick against the Droidbox on iOS screen mirror disappears after a few seconds. It is as if something is blocking the screen mirroring.

    Is anyone else also experiencing this with the latest versions of iOS? Is it something Apple has broken with their recent updates? Does the Airplay app on the Droidbox need updating? If so I can’t find an updated version on the Droidbox Market or on the Google Play Store.

    I have so many questions and no answers and it is driving me a bit crazy that I can’t get it to work when previously it worked like a dream.

    Any help would be greatly appreciated. Thanks in advance for any assistance anyone can provide.
     
  2. sean99

    sean99 Well-Known Member

    Apple are renowned for breaking things, I was a firm believer in ios until I switched to android a couple of years ago. Never looked back since. Is tbere no way you can get those same ios apps on the android platform directly on your box? Never been a fan of mirroring as was trying that years ago with not much success on ios as its all over wifi with plenty of outside interferance to scupper any plans.
     
  3. ajph1970

    ajph1970 New Member

    Hi sean99, thanks for your reply. Yes, you are quite right, Apple are well known for breaking things that previously worked. I’m heavily invested in the Apple ecosphere because of my work, so I’ll have to suck it up. I have to admit I didn’t even consider native Android apps, however, the issue there is I’ve got subscriptions on the Apple App Store which I don’t think would transfer over to android. Great idea though.

    I’ve now reached out to Apple to justify why Airplay no longer works for streaming to what is effectively an AppleTV through the Airplay server on Droidbox. It just seems so strange that it worked perfectly before the iOS updates. It made me wonder whether there needed to be an update on the Droidbox software to accommodate the new standard of Airplay 2. I might have to email the Droidbox support to see what they think.

    Again, many thanks.
     
  4. S Cristian

    S Cristian Cris Staff Member

    We are aware of the AirPlay issue, and we are sorry for that. Our developers are hard at work trying to fix it and push the updates.

    Please make sure you keep an eye out on our Blog to be the first one to find out when it is released.
     
  5. ajph1970

    ajph1970 New Member

    Hi,

    That’s useful to know. I figured it might require an update to the firmware. I shall look out for the update. Although I’m also currently experiencing problems updating my Droidbox following a full factory reset. I just keep getting a ‘failed to connect to server’ error.

    I’ll raise another query if I can’t get it to connect and update via the OTA update service.

    Many thanks
     
  6. Nigelar

    Nigelar Well-Known Member

    That error message usually means your box is up to date in terms of ota updates so can be ignored.
     
  7. ajph1970

    ajph1970 New Member

    Ah okay, cool. Good to know. Thanks for the reply. Much appreciated.
     
Loading...

Share This Page