1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Daughter bought me a RG350M for Father's Day....

Discussion in 'RG350 & RG350M Retro Games Handheld' started by mrleelee, Jun 26, 2020.

  1. mrleelee

    mrleelee New Member

    Absolutely loved it for the first week but now I've hit an issue and i'm concerned that it might not be fixable...

    Yesterday, I accidentally deleted the 'apps' section (thought I was deleting one app, not the whole section). I Googled it and saw that the section should return to normal if I hit the power button and the select button. I stupidly done this without really thinking it through. The screen went blank and wouldn't turn back on.

    I thought it was just lack of charge or something so plugged it in, the LED went red and I left it charging for a couple of hours. Unplugged it, tried to turn it on and nothing.

    I noticed the memory card (the one with the sticker over it) was sticking out slightly, so tried to push it back in but couldn't do this without taking the sticker off. Took the sticker off and the memory card wasn't in properly (I'm 100% sure it was in properly from the start so I am guessing I might have accidentally bumped it at some point).

    The LED is a very faint green even when it's not plugged in, like it's on but not :(.

    I have read that unscrewing the back and disconnecting the battery COULD be a fix for this, but I really don't want to open the machine up and experiment (I have had it for like a week).

    Any one have any ideas?
     
  2. VikramDroix

    VikramDroix Administrator Staff Member


    I would recommend to try a firmware re-flash following the guide HERE. This will hopefully fix the issue :).
     
  3. mrleelee

    mrleelee New Member

    Thank you for your reply.

    It seems to me like it's still on (because of the dim green light) but not actually on so I think I am going to leave it like that for a couple of days then if the battery runs down completely hopefully it will go off properly, then when I charge it, it will hopefully come back on.

    Nothing is ever that perfect though so I will probably be trying your suggestion when it doesn't work :D
     
  4. mrleelee

    mrleelee New Member

    Just a quick update to this.

    Looked at my 350M this morning and the dim green light wasn't on. Plugged it in to start charging and the loading screen came up. It then booted up normally (other than the time and date being wrong). The section that I had accidentally deleted before was back there as well.

    So a happy ending to this story :) Thank again for your suggestion!
     
    ChrisM and VikramDroix like this.
  5. gareth.uk

    gareth.uk New Member

    Just in case anyone else does anything like this, all you would need to do is remove the memory card and re-flash it with the firmware image. This would work regardless of what you had deleted from the card - even formatting the card completely can be recovered from with a re-flash. So there's never any reason to worry. :)
     
Loading...

Share This Page