michael hirons

New Member
Mar 5, 2020
I have two Droix x3 boxes One for the Lounge and One in my Bedroom,My Router is a Plusnet Hub1 with dual band 2.4/5ghz Capability.Can anyone please advise me how to set them up on a wavelength which wont interfere with other wifi devices operating at 2.4ghz NB My Router is not using the Smart Mode so shouldnt have problems staying on the wavelength ive set.
Can someone also explain why in Network settings Android 9,two connections are shown,I use Plusnet as my ISP[one for 2.4ghz the other for 5ghz,only one is showing as connected the other as saved?What does that mean?
Any help appreciated Michael


Well-Known Member
Feb 26, 2015
The channel ("wavelength") settings you refer to, to use less congested channels, are made on the router rather than your Droix box so you'll need to refer to the router user guide to change those.

Most routers now transmit 2.4g and 5g signals. 2.4g is best for distance and "sees through walls" better than 5g. 5g is faster but works best when you have line of site to the router.

The 2.4g signal is normally picked up by most mobile devices as the default and the connection is made to that automatically. You can switch to the 5g signal if you need that faster connection (and you have line of site to the router).
For my router i had to enter the router password for both to enable the connections.

If at all possible an ethernet (wired) connection will give you the best service.
  • Like
Reactions: VikramDroix


Staff member
Jul 15, 2014
Cardiff, UK
It sounds a bit like he has two different WiFi networks, one specifically for 2.4GHz connections, the other for 5GHz connections (I'm with PlusNet as well).

Whilst Nigelar's advice above definitely holds true if your modem/AP uses both frequencies on one network, if you deliberately have two different WiFi networks, then I would advise:

In the Droix device's settings, clicking on the network you want each device to use, and selecting connect.
Make sure the signal is strong enough. If you're certain it is OK and you WANT to have the devices stick to "their" network, then click on the other network and select Forget Network, or words to that effect. If it only offers to connect, you can leave the menu - you haven't got the password stored, so the device won't switch networks on you without your intervention.

Excuse the long delay with this response, not on the forums as much these days.