DroiX Summer Sale 2021 Advertisement

Shawncck

New Member
Jun 19, 2019
5
0
1
Hi, I do a few flash using different rom on my box. Then I did a TWRP restore and when it is done at 100 percent, it appear an error with invalid directory. And I reboot. Afte that, there was no more power on my box and I am unable to power it up and see anything on screen. Signal was not able to go to my HDMI. And I try to use PC to flash, but my PC was no longer able to flash it. I do not think it is a power issue as i was not able to flash it too. Anyone have any solution. Thanks.
 

Nigelar

Well-Known Member
Feb 26, 2015
3,549
1,073
113
You should ask your box supplier if they can provide the original firmware and try reflashing it. There is a strong chance that the firmware used on the Droix supplied machines would not be compatible in any case.
 

Shawncck

New Member
Jun 19, 2019
5
0
1
The problem here is i am not able to flash. Bcos there is no power light and the box no longer detected by my PC.
 

Nigelar

Well-Known Member
Feb 26, 2015
3,549
1,073
113
It may be coincidental but try a different power supply if you have one. The original may have broken.
 

Shawncck

New Member
Jun 19, 2019
5
0
1
It may be coincidental but try a different power supply if you have one. The original may have broken.
I did try the power supplier to another box. The power supplier is working fine. So i think is the flashing that caused it. I try to do a TWRP restore from Pie to Oreo.
I guess it cant be done. Any idea?
 
GPD WIN 3 with Dock and Case Sale