1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HDMI CEC

Discussion in 'T8-S Plus v2' started by very_random_man, Sep 19, 2017.

Tags:
  1. very_random_man

    very_random_man New Member

    Hi. I recently got a t8-s plus v2 and I'm struggling a bit to get the HDMI CEC working. I found the settings for the CEC Adapter under Input > Peripherals but it doesn't seem to work. The weird thing is that I'm pretty sure it worked to some degree when i first configured it.

    Has anyone else had any issues with it? Would anyone be able to direct me to some documentation or configuration tips, please? :)

    My set up is Droidbox > Onkyo AV receiver > Panasonic TV. I also have a Chromecast and a PS4 plugged into the AV receiver and they work fine with HDMI CEC.
     
  2. Bollocks77

    Bollocks77 Active Member

    I used CEC on my T8 Mini and my TV remote could control everything. I am sorry I cant help with your box model but surely there must be a way.
    Dave
     
  3. very_random_man

    very_random_man New Member

    Yeah i reckon so. I'm certain it was working briefly when i first turned it on. Do you think this is a Restore to Factory Settings job? ;-)
     
  4. 8bitDev

    8bitDev Moderator

    Hi

    Can you tell us if you tried to perform factory reset on your box and if it make any difference?

    Regards
     
  5. Bollocks77

    Bollocks77 Active Member

    Im not sure mate. I never had to.
     
  6. very_random_man

    very_random_man New Member

    I tried a factory reset and it still wouldn't work. Should it work out of the box?

    Just trying to think how best to test where it's going wrong. I suppose I could plug it directly into the TV and see if that works.
     
  7. very_random_man

    very_random_man New Member

    Right. I seem to have got to the bottom of the problem!

    It's not a software thing. The HDMI cable that came bundled with the Droidbox isn't good enough. I swapped cables with my PS4 and it's working properly now. I think cables need to be HDMI 1.4 compliant. I'd imagine 3D probably wont work with it either. I guess I must have been hallucinating when i thought it was working. ;-)

    I think I would have preferred to receive no cable than one that didn't do the job. No matter though as it's working now. :)
     
  8. Nigelar

    Nigelar Well-Known Member

    I had a similar issue when connecting my tv to a soundbar. I tried some of my spare old hdmi leads and they didn't work. I bought a better spec one off amazon and it worked.
    The usually supplied hdmi from droidbox is good enough for normal tv connection which is most people's need.
    Your experience and mine suggest that buying better quality leads (or optical) is recommended when using digital music connections on any device.
     
  9. 8bitDev

    8bitDev Moderator

    Hi

    Thank you for letting us know.We will investigate the issue and see where did the problem occur.

    Can you tell us if you only changed the lead,or hdmi port together with the lead that was used before?

    Regards
     
  10. very_random_man

    very_random_man New Member

    Hi. I basically unplugged the PS4 and plugged the cable into the back of the Droidbox. So it's technically possible it's not the cable but the HDMI port on my AVR. I've ordered a new cable anyway so I'll be able to confirm or deny this in a few days. :)
     
  11. 8bitDev

    8bitDev Moderator

    Hi

    Please re check with the cable supplied by us once more as it can be that MHL based hdmi port caused the issue.

    Regards
     
  12. very_random_man

    very_random_man New Member

    There is an MHL port on the AVR but I wasn't using it. I was using a port designated for Blu-ray players which is CEC-enabled. I'll do a more thorough test when i get a moment next week and let you know. :)
     
  13. 8bitDev

    8bitDev Moderator

    Thank you for letting us know.

    Regards and have a nice weekend ;)
     
  14. very_random_man

    very_random_man New Member

    Hi folks. I'm sure you've been biting your nails waiting for an update! ;-)

    I can confirm that the cable was the issue. The Kodi wiki seems to indicate there may be a problem with less expensive cables (http://kodi.wiki/view/CEC#Common_Issues_with_CEC). No matter though as it's working now. I probably ought to state that I've always been very happy with my Droidbox and have just been trying to iron out some kinks. :)

    On a related note, is there any configuration or button press on the remote that would use CEC to change AVR source back to the Droidbox when it's already switched on? Source-switching works fine on startup but if I've got the Droidbox and PS4 both on, how would i switch back to the Droidbox. With the PS4 you just press the PS4 button on the controller and it sends some kind of active source message and the AVR switches over to it.
     
  15. 8bitDev

    8bitDev Moderator

    Hi

    This should be available for change in the AVR switch itself,or if there is a hdmi input that takes priority you can use it to set the one that you prefer.

    Regards
     
Loading...

Share This Page