1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with Smart Multimedia Player Model Q7 Rockchip RK3188

Discussion in 'General Discussion' started by christiam.coronado, Aug 31, 2017.

  1. christiam.coronado

    christiam.coronado New Member

    I’m new to this sorry if I post this I on the wrong place:
    Hello fellow geeks. I’m going straight to the point I have an Android Smart Multimedia Player Model Q7, I believe it is a RK3188 not sure though. I rooted this android box with kingroot (successfully) and root uninstalled some system apps that I found irrelevant. Unfortunately, I think I have uninstalled some severe apps that this device requires to run. Well anyways now that I power it on all I get is a continues android LOGO that never advances to anything. It just stays there with the words ANDROID glowing. I tried to use the recovery options (button) on the bottom of the android box. But when I do all I get is a dead android laying on his back with a red warning triangle appearing on top of the laying android (no other information appears on the screen other than a dead android with a red triangle). No, I did not install a custom recovery like cwm or others. May one of you android intellectuals please link me or give me a step by step on how to fix this Sh*T. In delay, I apologize for the improper grammar. Final note I have a funny feeling that I might have to install or push some sort of firmware / firmware update in order to fix this, my guess. Thank you all in advance.
     
  2. Nigelar

    Nigelar Well-Known Member

    If your box was supplied by Droidbox (this is their forum) there is a Q7 firmware here.

    https://droidboxforums.com/threads/firmware-links-for-q7-devices.4875/

    If your box is not supplied by them, there is no guarantee it will work and could make things worse.

    If not a Droidbox, have you tried your box supplier for help?

    You could also look at the firmware available at the freaktab site for your particular chipset/processor. But you will need to be certain of the chip so do some research into your box first.
     
  3. sean99

    sean99 Well-Known Member

    Hi if it is not a droidbox Q7 try these posts from freaktab here:- https://goo.gl/ycLezJ a member called adsi post the relevant files to get the recovery mode accessed.
     
Loading...

Share This Page