frankbradz

New Member
Aug 1, 2014
7
1
3
This morning I started iStream on my iMX6 box and I noticed under movies that all of my Indexers apart from IMDB are gone. When I go into the IMDB option and select a movie no sources are showing. I went into the settings and noticed that most of the Indexers and Sources that I was using have disappeared.

The same problem exists under the TV menu in iStream.

Any ideas what has happened and how I can resolve this issue.
 

ChrisM

Administrator
Staff member
Jul 15, 2014
4,188
672
113
Cardiff, UK
ChrisMerriman.com
Last edited:

ChrisM

Administrator
Staff member
Jul 15, 2014
4,188
672
113
Cardiff, UK
ChrisMerriman.com
Right, partial good news!

I've found the same problem on my iMX6, and now the X7 also has the same problem (this isn't the good news part).

I've reset XBMC's data and followed a couple of procedures to get iStream installed AND working properly!

However, I now need to replicate the fix with a system set up as yours is - without XBMC's data having been reset (I'd prefer not to offer the only solution as one that involves losing any add-ons you've installed, configuration tweaks etc).

I've got my fingers crossed the procedure will remain the same, but it is 1.10am where I live right now, so it will need to wait until the morning for testing.
 

ChrisM

Administrator
Staff member
Jul 15, 2014
4,188
672
113
Cardiff, UK
ChrisMerriman.com
OK, the process is working on an iMX6 that I set up as a typical customer, now checking it works on Rockchip based devices then I'll post everything up.

I'll post a summary here, rewrite it properly later.

XBMC>System>Add-ons>Get add-ons>XunityTalk_Repository (need to double check this repo is visible without anything other than DroidBOX Wizard having been run)>Services>Xunity Talk istream extensions>Install (can't remember from my notes, go back a screen if necessary, to see the list of add-ons once more)>Coolwave istream extensions>Install... I think I didn't even need to restart XBMC, but it won't harm to do so at this point>Load iStream, smile as normal service is resumed.
 
  • Like
Reactions: smoggy

ChrisM

Administrator
Staff member
Jul 15, 2014
4,188
672
113
Cardiff, UK
ChrisMerriman.com
Confirmed and corrected version:

XBMC>System>Add-ons>Get add-ons>.XunityTalk_Repository>Services>.Xunity Talk istream extensions>Install>Coolwave istream extensions>Install ...

Load iStream, smile as normal service is resumed.
 

frankbradz

New Member
Aug 1, 2014
7
1
3
Confirmed and corrected version:

XBMC>System>Add-ons>Get add-ons>.XunityTalk_Repository>Services>.Xunity Talk istream extensions>Install>Coolwave istream extensions>Install ...

Load iStream, smile as normal service is resumed.

Just tried this and iStream is working again. Thanks for taking the time to help.
 
  • Like
Reactions: ChrisM

frankbradz

New Member
Aug 1, 2014
7
1
3
Issue happened again yesterday. Was able to resolve it again with your solution. Any idea why this has happened again?
 

ChrisM

Administrator
Staff member
Jul 15, 2014
4,188
672
113
Cardiff, UK
ChrisMerriman.com
Hmm. You could try temporarily disabling the DroidBOX Wizard add-on, uninstalling iStream entirely, installing it via a repository - https://seo-michael.co.uk/how-to-install-istream-for-xbmc-manually/ (you can probably skip to about halfway down the guide, where it tells you to install via ZIP, as the repo should be present, perhaps with a different name). Run through the steps, repeat the part in this thread if it doesn't yet work, then don't enable and run the DroidBOX Wizard for 3 or 4 weeks. If iStream continues to work, re-enable the DroidBOX Wizard add-on, and see if problems re-occur.
In short, no I don't know why this happened, but we may be able to rule out/in causes if we try the approach above.
 

Dusty16

New Member
Oct 18, 2014
7
0
1
Just wondering if anyone can help me set up the playlist via IMDB as there is no advanced settings on my istream. I thought we had to put in our ur number etc to link it.
 

ChrisM

Administrator
Staff member
Jul 15, 2014
4,188
672
113
Cardiff, UK
ChrisMerriman.com
Some the screenshots may be out of date, as the video is from February, but if you follow the steps here -
- are you definitely missing the required menus he uses? I'll mention this with the assumption that it is un-necessary, but you're comfortable with accessing add-on's configuration menus, yes? As in highlight the add-on, don't click it, but press the Menu button on your remote control, or the C button if you have a QWERTY keyboard on your remote.
 

Dusty16

New Member
Oct 18, 2014
7
0
1
You were right in putting the last section as I was unaware of the fact you could press c for a menu. I still cant get the advanced menu up though (probably me not doing it right ha ha). Could it be the fact I have a different skin and not the istream one?

I will go bacl through the vid and make sure I have not missed anything

thanks for your help
 

Dusty16

New Member
Oct 18, 2014
7
0
1
Hi I must be doing something wrong I really can't find an advanced menu on istream where I can put my ur number

thanks
 

ChrisM

Administrator
Staff member
Jul 15, 2014
4,188
672
113
Cardiff, UK
ChrisMerriman.com
OK, I've just checked through, let me know whether this is the right area, or if you don't see the same options as me, let me know at which point you see different/missing entries...

iStream>Settings>Movies>IMDb>User Number

I'm assuming it carries across that number to

iStream>Settings>TV>IMDb>User Number

as well, but it might be worth a check.