vkaile

New Member
Nov 13, 2019
4
0
1
Where to copy Mame Roms on RG350 , as the two emulators on it are not able the find the Mame Roms on the External SD Card, Kindly Help
 

Dave C

Guest
Staff member
Sep 1, 2015
999
89
48
London
www.droix.co.uk
For XMAME the files need to be on the internal storage at /media/data/local/share/xmame/roms .

I have not tried this on the RG350 but if make an APPS folder on the external card, then copy the contents of /xmame/ to the APPS folder, it should work if you add the files there instead of internal.

This may also work for MAME4ALL

Please also check that you are using the correct MAME romset for the version.
 

vkaile

New Member
Nov 13, 2019
4
0
1
Where to copy Mame Roms on RG350 , as the two emulators on it are not able the find the Mame Roms on the External SD Card, Kindly Help
For XMAME the files need to be on the internal storage at /media/data/local/share/xmame/roms .

I have not tried this on the RG350 but if make an APPS folder on the external card, then copy the contents of /xmame/ to the APPS folder, it should work if you add the files there instead of internal.

This may also work for MAME4ALL

Please also check that you are using the correct MAME romset for the version.

copied one rom from the 0.37b5 romset into the above mentioned folder, it still didnt seem to find it
 

Dave C

Guest
Staff member
Sep 1, 2015
999
89
48
London
www.droix.co.uk
Highlight the XMAME icon and press SELECT, there is an option to read the manual for it. All the information on which romset it requires is on there. I just checked the folders and there should be

/media/data/local/share/xmame/xmame52
/media/data/local/share/xmame/xmame69
/media/data/local/share/xmame/xmame84

and in each folder should be a rom folder. You need to copy the correct romset depending on the version of the emulator you are using, you can switch between them on the emulator menu with the R trigger. You may need to refresh the list by pressing START.
 

vkaile

New Member
Nov 13, 2019
4
0
1
Highlight the XMAME icon and press SELECT, there is an option to read the manual for it. All the information on which romset it requires is on there. I just checked the folders and there should be

/media/data/local/share/xmame/xmame52
/media/data/local/share/xmame/xmame69
/media/data/local/share/xmame/xmame84

and in each folder should be a rom folder. You need to copy the correct romset depending on the version of the emulator you are using, you can switch between them on the emulator menu with the R trigger. You may need to refresh the list by pressing START.

yes already read the manual and downloaded the mentioned romset 0.37b5, and yes copied the roms in the above mentioned roms folders of each version individually, it did not recognize / find any rom except its preloaded rom , 1 in each rom folder ........
 

Dave C

Guest
Staff member
Sep 1, 2015
999
89
48
London
www.droix.co.uk
Are you copying them to the internal storage? Did you press START after switching between versions (Right trigger)? I tried this earlier and it worked fine. I have not had a chance to see if the external card method works or not.
 

vkaile

New Member
Nov 13, 2019
4
0
1
Are you copying them to the internal storage? Did you press START after switching between versions (Right trigger)? I tried this earlier and it worked fine. I have not had a chance to see if the external card method works or not.

yes copied them in internal memory and yes switched via right trigger , the copied roms are not visible , only the preloaded one single rom in each version is visible
 

Dave C

Guest
Staff member
Sep 1, 2015
999
89
48
London
www.droix.co.uk
You may have the wrong romset for the version of XMAME folder. There are three versions of XMAME, so try pressing Right Trigger then START to refresh for each version. My only other suggestions is if you are not already on the latest firmware, v1.6 at the time of writing this, you can try updating. There is a guide in the forum.
 

islandsnow

New Member
Dec 4, 2019
1
0
1
where exactly is the mame emulator (xmame or mame4all) getting its list of games from? when i look at

/media/data/local/share/xmame/xmame52/roms
/media/data/local/share/xmame/xmame69/roms
/media/data/local/share/xmame/xmame84/roms

and its all empty
 
Dec 31, 2019
1
3
3
I registered on this website just to add this note:

I was trying to add my MAME Roms to my external SD card, instead of the internal storage, for use with XMame. This worked for me:

I copied my Mame Roms to my SD card, put the SD card into the RG350, connected the RG350 to my computer and logged into it with WinSCP (after starting the Network app on the RG350 of course).

Then I used WinSCP to rename:
/media/data/local/share/xmame/xmame84/roms​

to something else, like:
/media/data/local/share/xmame/xmame84/roms_backup.​

I then used WinSCP to make a link from the roms folder on my SD card:
/media/sdcard/<location of your 0.84 roms>​

to:
/media/data/local/share/xmame/xmame84/roms​

It worked perfectly!

Don't forget, after you've used the L and R buttons to select xmame.SDL.84 [ALL Games xxxx] (or whatever applies to your scenario), you have to hit the Start button to refresh the ROM list cache (even though the built in manual says it's the select button, at least on my version).
 

fasigit

New Member
May 9, 2020
3
0
1
Hi, I download MAME ROMs and I download MAME Emulator, but now I found that there are so many different versions of MAME games: MAME 1.uo12 or MAME 1.11 for example, my question is how to find the emulator for the exact MAME ROMs. Is there a different emulator for different MAME console or with the standard MAME emulator you can play all these different types of MAME ROMs?
 
Last edited by a moderator:

resplined

New Member
Jun 5, 2020
1
0
1
I registered on this website just to add this note:

I then used WinSCP to make a link from the roms folder on my SD card:
/media/sdcard/<location of your 0.84 roms>​

to:
/media/data/local/share/xmame/xmame84/roms​

Thanks for the tip. I tried this on my PocketGo 2 but kept getting errors in WinSCP. What ended up working was to SSH into the PocketGo2 and create the link that way. Like this:
ln -s /media/sdcard/<location of your 0.84 roms> /media/data/local/share/xmame/xmame84/roms
 

JusR23

New Member
Jul 15, 2020
2
0
1
I registered on this website just to add this note:

I was trying to add my MAME Roms to my external SD card, instead of the internal storage, for use with XMame. This worked for me:

I copied my Mame Roms to my SD card, put the SD card into the RG350, connected the RG350 to my computer and logged into it with WinSCP (after starting the Network app on the RG350 of course).

Then I used WinSCP to rename:
/media/data/local/share/xmame/xmame84/roms​

to something else, like:
/media/data/local/share/xmame/xmame84/roms_backup.​

I then used WinSCP to make a link from the roms folder on my SD card:
/media/sdcard/<location of your 0.84 roms>​

to:
/media/data/local/share/xmame/xmame84/roms​

It worked perfectly!

Don't forget, after you've used the L and R buttons to select xmame.SDL.84 [ALL Games xxxx] (or whatever applies to your scenario), you have to hit the Start button to refresh the ROM list cache (even though the built in manual says it's the select button, at least on my version).
This has just helped me massively I can now pop the sdcard out and set up my ROMs. Thank you :)
 

Tim Woodward

New Member
Jul 18, 2020
3
0
1
Thanks for the tip. I tried this on my PocketGo 2 but kept getting errors in WinSCP. What ended up working was to SSH into the PocketGo2 and create the link that way. Like this:
ln -s /media/sdcard/<location of your 0.84 roms> /media/data/local/share/xmame/xmame84/roms

Hi can you please explain how you did this? I’ve done all the steps detailed in the post above but I just don’t understand about linking the ROM folder.
Thanks
 

Interim Lovers

New Member
Nov 8, 2020
7
0
1
I've just started playing MAME ROMs on my RG350. Mainly, I'm playing Ghosts & Goblins and Gauntlet and they work great - especially on MAME4All. I'd love to play R-Type but none of the ROMS I've found seem to work. If I try to load them in XMAME or MAME4All it says there are file missing. In FBA, the ROMs basically work but the frame rate is terrible. Can anyone give me tips on how to trouble-shoot this?
 

BenDroiX

Guest
Staff member
Jun 19, 2019
164
8
18
I've just started playing MAME ROMs on my RG350. Mainly, I'm playing Ghosts & Goblins and Gauntlet and they work great - especially on MAME4All. I'd love to play R-Type but none of the ROMS I've found seem to work. If I try to load them in XMAME or MAME4All it says there are file missing. In FBA, the ROMs basically work but the frame rate is terrible. Can anyone give me tips on how to trouble-shoot this?

This could be any number of things really.
- It could be you're using a clone ROM instead of the original
- It might be a ROM compiled for FBA instead of MAME

etc.

Have you tried redownloading the R-TYPE rom from elsewhere?
 
GPD WIN 3 with Dock and Case Sale