1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems connecting with IPVanish

Discussion in 'X7 and X7 Ultimate' started by Amber27, Jul 12, 2017.

  1. Amber27

    Amber27 New Member

    I've had my X7 for a while now and it works pretty seamlessly. Now I need to use a VPN, so - following advice from several sources - I signed up with IPVanish. I've tested this on a PC and it works fine.

    However, on the X7, I first installed the app, and despite seeming to work, the connection always got stuck on 'Assigning IP' (the last stage of connection, I presume). Their helpdesk suggested I try a manual set-up, which I did - firstly with a PPTP configuration and - when that didn't work - with L2TP.

    PPTP just does nothing - I hit connect and it goes back to the previous screen and I'm still connected without VPN. Furthermore, when I tried the 'Always-on VPN' option, there was only one option: 'None'.

    With L2TP, the connection window still yields nothing, but at least the VPN features in the 'Always-on' list as an option. However, when I hit OK, I'm taken back to the Droidbox homepage. Incidentally, I was made to set a PIN for the box when I first tried the 'Always-on' option.

    After all this, I reset the box, thinking the VPN might work after a reboot. Instead, it came back up - after a long wait and 2 requests for the PIN - showing a 1 Jan 2011 date and no connection for any apps, despite the ethernet set-up screen showing the normal details. I had to do a factory reset to get it working again, so I'm naturally a little wary of trying again.

    Has anyone else had these problems or have any idea what might be going wrong? IPVanish seem to be out of suggestions. Thanks in advance.
     
  2. ChrisM

    ChrisM Administrator

  3. Amber27

    Amber27 New Member

    Thanks for getting back. I installed tun.ko and get the following:
    "Tun module is loaded
    TUN support is possibly pre-loaded in your kernel.
    You can now use DroidVPN or OpenVPN."

    There is an 'Install' button at the bottom of the screen, which I tried. After a few minutes, it came back and said there was no compatible module, so mixed messages (or am I misunderstanding?).

    Rebooting and trying IPVanish results in no IP being found, and when I try to connect, it's still hanging on 'Assigning IP'.

    Incidentally, I toyed with manually setting up a VPN again, but it's at that stage (not 'Always-on', as I said before) that I'm told I need to set a PIN or password. Since this seemed to have confused the box considerably the last time, I'm reluctant to try again. Is there a way around it?
     
  4. Amber27

    Amber27 New Member

    Correction: the exact message is 'Downloaded module is incompatible!'.
     
  5. ChrisM

    ChrisM Administrator

  6. Amber27

    Amber27 New Member

    OK, thanks.

    Yes, the IPVanish app is properly set up and for updates.

    I hadn't tried OpenVPN. I've done so now. I get as far as signing in, press 'Connect', get the 'do you trust this app...' message, hit OK and then ... nothing. Just the same as when I've set up the VPNs manually.
     
  7. Bollocks77

    Bollocks77 Active Member

    I know Ive seen it somewhere but is there an idiots guide to installing on Leebrelec side as I dont use Android.
    Thanks everyone.
     
  8. ChrisM

    ChrisM Administrator

    @Amber27 If IPVanish don't have any more suggestions/fixes either, it might be time to cancel the account, assuming you only use the VPN on your DroidBOX.

    @Bollocks77 There are a few threads on it here in the forum, looks like StringyMCFC has it set up nicely, going from https://droidboxforums.com/posts/38819/
     
  9. angela

    angela Well-Known Member

    Hi, this is the best post by StringyMCFC for using a VPN in Libreelec.

    https://droidboxforums.com/threads/vpn-for-libreelec-advice-needed-please.10195/

    You say in another post you don't like flashing or maybe using samba or sd card.
    One solution if you wanted to do it is install one of Sean's builds that has the Zomboided repository all ready installed to get VPNManager for OpenVPN then follow StringyMCFC post to install your VPN, then uninstall the addons/repos you don't want or add your own then switch to the Confluence skin you prefer.
     
  10. Amber27

    Amber27 New Member

    Thanks. Do you have any suggestions for a safe, free VPN service that I can try out to see if it's an ipvanish problem?
     
Loading...

Share This Page