1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PS1 EMULATOR BITTBOY

Discussion in 'BittBoy and Pocket Go Retro Gaming Handheld' started by Radarman13, May 15, 2019.

  1. Radarman13

    Radarman13 New Member

    Hi everyone just received and upgraded my Bittboy to firmware 3.7 but i'm unable to launch Roms on Ps1 emu...just black screen, any help ?
     
  2. Dave C

    Dave C Administrator Staff Member

    You will probably need to add the PlayStation BIOS.
     
  3. Radarman13

    Radarman13 New Member

    Yeah found the roms were zipped into 2 files .cue and .bin , but on 5 games i have only one is starting....
    Can someone post a guide for firmware 3.7 on Bittboy ? there are so many functions and programs on it i don't know how they works..
     
  4. Dave C

    Dave C Administrator Staff Member

    PlayStation games should always be unzipped, they are too large in size. Note that PS1 emulator runs quite slow on many games if they run at all.

    I do not think there are any guides for the emulators but if you have any questions you can ask here.
     
  5. b-boy_steve

    b-boy_steve New Member

    Well, i have the same problem... Im trying to run gran turismo 1 on my bittboy (its working on others bittboys on internet) and there is a black screen when i launch the game (any ps1 game!!!). I have already save one bios file (SCPH1001.bin) on emus/pcsx_rearmed/bios forder... What am i doing wrong??? My bittboy is v3.5 and running v3.9.
     
    Last edited: Jun 28, 2019
  6. b-boy_steve

    b-boy_steve New Member

    Ok i find out what is wrong...
    Its calling cpu throttling... But i have a solution!
    Bittboy default cpu speed is 702mhz... So you have to reduse that speed to 650mhz... For doing this go from your pc to:
    main/gmenu2x folder and find gmenu2x.conf. Open that file using notepad , find cpuMenu=702 and change 702 to 650 (cpuMenu=650) then save and quit. Insert sd card on bittboy. Then from your bittboy find ps1 emulator and push select button, edit ps1, cpu clock 654.
    Done!!! Everything is working now!!!
    If you wish to add your own bios then you have to copy-paste your bios on main/emus/pcsx_rearmen/bios folder.
    After that just launch a game go to options---> bios and select your own bios file... Save and restart your game!
    Done!!!
     
  7. odibeajde

    odibeajde New Member

    Did this work for you, I try to make the changes that you write above but after games start to play I lost the sound of the games. At the start like the other member said black screen I made the changes and no there is no sounds on my bit boy. Is there any other PS1 Emulator from here retrostic.com that I need to install or the game is the problem I don't know.
     
    Last edited: Sep 16, 2019
  8. b-boy_steve

    b-boy_steve New Member

    Hmmm... What is your bios file? Did you change them?? Or you still use hle bios???
     
  9. odibeajde

    odibeajde New Member

    Still, use the hle bios is it need to change that too?
     
  10. b-boy_steve

    b-boy_steve New Member

    Yeap... I have many sound problems with hle... Try anything else. You cant even save with hle bios...
     
Loading...

Share This Page