One Netbook ONEXPLAYER 1S Gaming Handheld

tsukaito

New Member
Nov 1, 2021
2
0
1
I have an RG 300 v1 with IPS Display. After some weeks of no need I try to play with the RG 300 (after loading the batterie) but I get only the boot screen "Retro FW Version 2" and then NOTHING. Sometimes I got flickering colors an the screen, sometimes only black screen. The system stucks...
I do no update or anything I don't use the handheld for some weeks only.
I tried to reseat the cables, batterie and sd-card - nothing! I tried to use a new sd-card with new firmware - nothing!
Do someone have an idea what I could do to get my RG300 back?

Plz help me...thanks for any kind of help!
tsukaito
 

Attachments

  • Bootscreen.jpg
    Bootscreen.jpg
    234.8 KB · Views: 13
  • Bootscreen_2.jpg
    Bootscreen_2.jpg
    448.3 KB · Views: 13
  • Bootscreen_3.jpg
    Bootscreen_3.jpg
    480.9 KB · Views: 14

BenDroiX

Guest
Staff member
Jun 19, 2019
213
16
18
Are you certain you're using the right version of RetroFW?

There's a lot of different versions of RetroFW, so you might not be picking the right one.
 

tsukaito

New Member
Nov 1, 2021
2
0
1
Hi BenDroix,

thanks for your reply. I tried all Types of Firmware to install on a new SDCard (16GB and 64GB). Only the Type 5B gave me a picture but stucks also.
When I turn on the handheld I get a black screen or stucks at "RetroFW" bootscreen.
Can this be an hardware issue or is there an diagnostic option to find the porblem?
What can I do to troubleshoot this error?

Thanks for any type of help!
tsukaito
 

BenDroiX

Guest
Staff member
Jun 19, 2019
213
16
18
If trying different SD cards and firmware didn't resolve the issue, it it's almost certainly a hardware problem. It could be something on the board itself is messed up.

If it's still within its warranty period I'd advise contacting the original seller.
 
GPD WIN Max 2021 Release