Android TV Boxes from DroiX

Dan4232

New Member
Dec 31, 2015
2
0
1
My T8 has stopped working. Really, just stopped. I've tried the restore, nothing. Nothing will come up, won't boot, all that is working is the power button. Any ideas what I can do?
 

8bitDev

Moderator
Jul 2, 2015
708
117
43
My T8 has stopped working. Really, just stopped. I've tried the restore, nothing. Nothing will come up, won't boot, all that is working is the power button. Any ideas what I can do?
Hi


Something that would be really great to check and if you can reply back to us with details:

1-Can you please check light indicators:
-RED LIGHT-power is ON but box is OFF
-BLUE LIGHT-box is ON
2-Check LED screen on the box.
While box is booting up on small LED you will see message -boot-.when box is finally turned ON fully,you will see time displayed on small LED screen.

3-Are you using original power supply that came with the box?Can you please check power cord/jack that you are using?

4-Sometimes TV can cause the problems in displaying image,so if you could check hdmi source settings in TV that you used to assign to port that you are using for the box ?

When you check these above can you please write us back with replies!

Regards
 

Qaisir

Active Member
Nov 10, 2015
323
141
43
Try to factory reset your device and see if that works for you.
Follow the below video to factory reset your device:

Hope it helps you out.
 

Dan4232

New Member
Dec 31, 2015
2
0
1
I have had the box since August. It has worked perfectly fine up until 2 days ago. The red light comes on when power cord is in. When box is turned on, light turns to blue. It does not boot. Nothing comes up on LED screen. Restore has been tried several times, still nothing comes up on LED screen.
 

8bitDev

Moderator
Jul 2, 2015
708
117
43
I have had the box since August. It has worked perfectly fine up until 2 days ago. The red light comes on when power cord is in. When box is turned on, light turns to blue. It does not boot. Nothing comes up on LED screen. Restore has been tried several times, still nothing comes up on LED screen.
Ok

In that case please email us at support@droidbox.co.uk and we will move from there!

Regards
 

thewatchergb

New Member
Jan 31, 2015
12
1
3
Hi,

I have the same problem, I had done an update by the SD Card Method but I couldn't get the Wookie to load (after adding zip and naming it). I went back to settings and removed Kodi/spmc app and associated apps. When I tried to re-update still using the same SD card and method it wouldn't work. I have red/blue lights but no clock or boot on the LED screen. I had already performed the same procedure yesterday on my main T8 without any issues at all.

I am really not at all tech savvy so if you can help can you advise in the simplest layman's terms please.

Regards,
Tracey
 

Soufiene

New Member
May 17, 2018
3
0
1
Hi,

I have the same problem, I had done an update by the SD Card Method but I couldn't get the Wookie to load (after adding zip and naming it). I went back to settings and removed Kodi/spmc app and associated apps. When I tried to re-update still using the same SD card and method it wouldn't work. I have red/blue lights but no clock or boot on the LED screen. I had already performed the same procedure yesterday on my main T8 without any issues at all.

I am really not at all tech savvy so if you can help can you advise in the simplest layman's terms please.

Regards,
Tracey
I am having the same problem with a T8. It can't boot into system neither from an SD card. Did you find an issue?
 

Soufiene

New Member
May 17, 2018
3
0
1
My T8 has stopped working. Really, just stopped. I've tried the restore, nothing. Nothing will come up, won't boot, all that is working is the power button. Any ideas what I can do?
I am having the same problem with a T8. It can't boot into system neither from an SD card. Did you find an issue? Thanks.
 

charliemhh

New Member
Jun 23, 2018
3
0
1
Same problem here. I can’t do a factory reset. The blue light comes on, but nothing on the LED screen. It won’t boot up at all. Help please!!
 

Nigelar

Well-Known Member
Feb 26, 2015
3,586
1,079
113
The Droidbox T8 is an old machine.
Has this problem only just started after years of no issues?
Have you done anything e.g. tried updating firmware prior to the problem occurring?

Have you tried any of the following:
- making sure the hdmi lead is secure on both tv and your droidbox
- a different hdmi port on the tv
- a different hdmi lead
- a different tv
 

charliemhh

New Member
Jun 23, 2018
3
0
1
I’ve only just bought this box. (20 June) I keep having problems that it won’t boot up properly. The advice given was to do the factory reset, but it won’t even let me do that!
 

Nigelar

Well-Known Member
Feb 26, 2015
3,586
1,079
113
If you have just bought the box then it is probably the newer t8se or t8 s plus V2.
As you had posted in the t8 sub forum I assumed it was that older box.
Both the above machines have their own sub forums.

I think it would be best now to contact Droidbox support directly.
There's a "contact us" link at the bottom of the forum page. Quote your order id in your message.
 

Soufiene

New Member
May 17, 2018
3
0
1
Thank you - I have done. Yes, it’s a V2. Sorry if I’ve posted in the wrong place!

I solved this problem by installing a firmware from droidsticks, go to the following website and follow the instructions:

https://www.entertainmentbox.com/latest-t8-aml-v2-firmware-download/

Regards.

**********Admin Note by @Nigelar *******
Downloading firmware for another supplier's box is not a recommended path. Although it may have worked in this instance, there is no guarantee of compatibility with your particular box. There is a real risk of bricking your box.
@charliemhh , as your box is likely still under warranty please contact Droidbox as advised.
 
Last edited by a moderator:
Android TV Boxes from DroiX