1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

T8 completely dead

Discussion in 'M8 and T8 (Both with LED clock on the front)' started by Twitaker123, Oct 27, 2016.

Tags:
  1. Twitaker123

    Twitaker123 New Member

    Hey guys,
    Tried to boot my T8 today,
    And absolutely nothing happened, the standby button is red, when I press it nothing happens doesn't change blue, no boot on the LED, tried factory reset same thing nothing can't get anything to do anything? Any help?
     
  2. ChrisM

    ChrisM Administrator Staff Member

    @Twitaker123 Can you check the correct power supply is definitely being used please? If it is, can you let us know the specifications on it, it is the Volts and Amps/milliAmps that we're interested in.
    If you happen to have another 5V power supply with the same sized plug, could you also post up the specifications on that one - if it is suitable we could try using that temporarily as a test. If that fixes it, we can send out a new power supply, assuming it was a new device from us and within 12 months.
     
Loading...

Share This Page