One Netbook ONEXPLAYER 1S Gaming Handheld

skynet2001

Member
Jun 30, 2016
33
2
8
Several years i bought this wonderful box , best of 2 worlds, now i have to conclude that after a few years, that we are left standing in the rain.
No more update after Kodi 17.6 , in the meantime we are at Kodi 19.4.
Slowly the addons/kodi builds are only developed for 18 and further.
So eventually the libre elec part is dying in beauty.

Or has anyone found a solution so i can update to kodi at least 18 or more

Thanks for the help in advance
 

Nigelar

Well-Known Member
Feb 26, 2015
3,581
1,076
113
As long as your T8 runs android 5 (which I think it does), you should be able to grab Kodi 19 from the Google Play Store or the official Kodi site.
 

Nigelar

Well-Known Member
Feb 26, 2015
3,581
1,076
113
After using these machines for many years I have found the "android" kodi perfectly useable and still do if that is any consolation. Certainly i have never used the libre elec version. So if you want to continue using the machine for Kodi then my solution is to switch to the Android version.
 

BenDroiX

Guest
Staff member
Jun 19, 2019
248
22
18
There's no real workaround for getting the latest versions of Kodi to work on LibreELEC unfortunately. You could possibly go bug the developers to update it, but at the end of the day it's a community-developed application and thus long-term support can't be guaranteed for anything.

However, as Nigelar mentioned, you can easily grab the latest version of Kodi from the Google Play Store on the Android operating system, provided your device runs Android 5 or newer. It should be supported for a fair bit longer (Android 5 is about 6 years old at this point and is still supported by a huge number of developers).

If the overhead of Android is a bother, you can also delete unused apps in the system settings.
 

skynet2001

Member
Jun 30, 2016
33
2
8
Thanks for the clear reply, since the T8v1 is a S812 device , is it a option to install Libre elec for S812 or will this lead to issues
 

Nigelar

Well-Known Member
Feb 26, 2015
3,581
1,076
113
A quick google suggests you would need Librelec 10.x to support Kodi 19 (matrix). You would need to research if this runs on your machine.
I do not use Librelec and never have so can offer no more advice other than use the Android version of Kodi which is proven to work with no observable performance issues that I have seen.
 

BenDroiX

Guest
Staff member
Jun 19, 2019
248
22
18
Thanks for the clear reply, since the T8v1 is a S812 device , is it a option to install Libre elec for S812 or will this lead to issues
I would advise against it, but I can't confirm or deny if it would work since it's not something I've tested (or am able to test - we don't have any T8's lying around the office anymore).
 
GPD WIN Max 2021 Release