1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

T8-S Plus Write to Storage Devices Fix - November 2016

Discussion in 'T8-S Plus v1' started by ChrisM, Nov 10, 2016.

  1. ChrisM

    ChrisM Administrator Staff Member

    T8-S Plus v1 models only.
    Don't know which model you have? Don't flash this. If you have Android 6 on your device, or it mentions 905 instead of 812 when you check the details, you have a Plus v2, this fix isn't for you.

    -=-=-=-=-=-=-=-=

    We have created a fix for DroidBOX T8-S Plus users who are unable to write to "external" storage media (including SATA hard drives that physically internal to the T8-S Plus) inside Kodi.

    If the application you use to download asks for SuperSU/Root priviliges and you allow them, said app should already be able to write to your storage.
    No need to flash this if you don't have problems basically.

    If you do not want to follow this procedure, you can wait for the next OTA update which will have this fix included.


    Quick version: download the ZIP, stick it on an SD card, flash from Recovery Menu.

    1. Download the ZIP file attached to this post. DO NOT EXTRACT/EXPAND/UNZIP THIS FILE! If there is a problem with downloading from this forum, the file can also be found at https://droidboxcloud.co.uk/index.php/s/exJRa4wl0IZoB17


    2. Copy the ZIP file to an SD memory card. It can be any size, best to stick to one formatted with FAT/FAT32 please. If that means nothing to you, your card is probably alright.
    DO NOT USE A CARD THAT HAS PREVIOUSLY HAD FIRMWARE FILES ON IT UNLESS YOU FORMAT IT FIRST. REALLY VERY IMPORTANT.


    3. Turn your T8-S Plus off please. Don't forget to close Kodi/DBMC down properly first if they have been running.


    4. Insert the SD card into your T8-S Plus' memory card slot on the right hand side.


    5. If you're using a remote with Air Mouse functionality, please turn it over so the QWERTY keyboard is facing you.


    6
    . Hold down the "RESTORE" button on the right hand side of your device. Do not let go of it. You will need something like a sturdy cocktail stick or thin match to poke into the recessed area properly. If you can't see the hole, it is behind the USB sockets.


    7
    . Don't let go of the Restore button. Please. This won't work otherwise


    8
    . Turn your T8-S Plus on. See step 6 before continuing


    9
    . You'll see the first boot up image as normal, and then the Android Recovery Menu will appear.
    20161110_183030_0.png


    10a
    . If you can definitely see the Recovery menu, you can now let go of the Restore button on the side.
    10b. If your device boots up as normal (no text based Android Recovery Menu shown), you may have not been holding the switch in quite far enough. Turn off and start again at step 5 please


    11
    . Select the apply update from EXT option with your remote control. If you're using a remote with Air Mouse functionality then you can use the cursor keys and Enter/Return.
    20161110_183103_0.png


    12
    . Select the Update from sdcard option.
    20161110_183111_0.png


    13
    . Select the t8splus_fix_hdd_usb.zip entry and wait for the process to complete. The message that mentions /misc is normal and can be safely ignored.
    20161110_183126_0.png


    14
    . Select the Reboot Now option.
    20161110_183132_0.png


    15
    . Your device will now boot up as normal. The first screenshot is the animation seen by people with 1.0.4 or earlier firmware, the second screenshot is a confirmation of the normal boot animation seen by customers with 1.0.7 in place.
    20161110_183155_0.png
    20161110_184057_0.png



    If you encounter any problems, let us know which step you got to, what happened differently, and any messages seen on screen.
     

    Attached Files:

    Last edited: Feb 27, 2017
    David Savage and sblabs like this.
  2. EHTiger66

    EHTiger66 New Member

    this has broken my box can't see any drives/files even emulated even after a reset
     
  3. David Savage

    David Savage Moderator

    Try live chat today to see if the droidBOX team can help you. Live chat is on the main site and is office hours only.

    Best of luck
     
    sblabs likes this.
  4. sblabs

    sblabs Active Member


    that's odd it installed fine for me. do as Dave suggests.

    update: you DO need this .zip file when you have updated to v107 or v108
     
    Last edited: Jan 14, 2017
    David Savage likes this.
  5. EHTiger66

    EHTiger66 New Member

    Finally got chance to try some things today, but no luck.
    system reset, flash the zip , tried editing platform.xml but wouldn't save.
    tried some commands through a terminal but not playing (as mumblez post https://droidboxforums.com/threads/not-working-after-system-reset.7640/page-2)
    seems to be that the internal hd (flash) is not writable and i cannot change attributes.

    LibreElec is working fine, so i dont really want to return box unless necessary.

    will try and get on live chat but going to be hard as I will be at work!

    2016-11-13 11_49_19-Console.png 2016-11-13 11_29_41-Console.png
     
  6. 8bitDev

    8bitDev Guest

    Can you please flash latest firmware(1.0.7) and then use the one from the guide from the top?
     
    sblabs likes this.
  7. EHTiger66

    EHTiger66 New Member

    i cannot connect to the internet so i cannot download the latest OTA

    can you DM me alink for it ?
     
  8. ChrisM

    ChrisM Administrator Staff Member

    @EHTiger66 I've PMed you, just in case the forum doesn't notify you.
     
  9. EHTiger66

    EHTiger66 New Member

    Thanks to the guys at droid box up and running again :)
     
    David Savage and sblabs like this.
  10. Mark A. Miller

    Mark A. Miller New Member

    I've only had my T8-S Plus box for 2 weeks and I've been baffled why I couldn't download any content onto a USB stick nor SD card. Finally today I checked out this forum and thankfully the answer was already published here. I updated my box to the latest firmware (v1.0.7) and then followed the instructions on this post to install the fix. Everything went according to plan and now I am able to download content to a USB stick. :D

    I should point out that updating your firmware to v1.0.7 alone, will not fix the problem. You DO need to also install the fix. Thanks everyone at Droidbox.
     
    8bitDev likes this.
  11. RRaoD

    RRaoD New Member

    I got my T8-S box on 22 of January '17 and have updated the box to the latest firmware through OTA.

    Then I connected my 4TB NTFS external HDD and loaded the video files on to DBMC. I could add the movies and the scrapers have gathered the movie information, thumbnails and fanart on to the internal 32GB internal storage.

    When I tried to export the library to the external HDD, the export has failed to copy the nfo files, thumbnails and fanart. The DBMC has failed to write to the external 4TB drive.

    After reading this post, I applied the fix given by ChrisM and now the above problem is solved. Thanks ChrisM...

    This fix was not included in the latest January '17 firmware updates. I recommend to everyone who wants to write to the external drives to apply this fix.
     
  12. courtjester

    courtjester New Member

    Just got my T8-S Plus V2 box last week and noted this problem while setting everything up. Since I'm a novice when it comes to Android systems and, in light of above, not terribly confident in trying the above fix myself (don't have SD card anyway) in case it causes problems elsewhere. Think I'll wait for the OTA update which is mentioned - does anybody know when this will be available?
     
  13. sblabs

    sblabs Active Member

    Guys DO NOT USE THIS FIX on your T8 S Plus V2 box it will mess up your platform.xml

    THIS FIX IS ONLY FOR THE V1 BOX
     
    Last edited: Mar 8, 2017
  14. RRaoD

    RRaoD New Member

    Will this write enable fix works for both Android DBMC and LibreELEC Kodi 16.1?

    For me it has rectified on Android side, but on LibreELEC side I could not download any add-ons..
     
  15. sblabs

    sblabs Active Member

    this fix is for the Android side and only for the v1 boxes.
     
  16. RRaoD

    RRaoD New Member

    Then I need either a fix or a solution for my LibreELEC 7.0.3 Kodi 16.1.

    Is LibreELEC 7.0.3 Kodi 16.1 working smoothly for other V1 box owners?
     
  17. ChrisM

    ChrisM Administrator Staff Member

  18. RRaoD

    RRaoD New Member

    OK Chris... Thanks
     
Loading...

Share This Page