1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

T8 V2 needs firmware upgrade

Discussion in 'General Discussion' started by Scrobster, Jan 18, 2017.

  1. Scrobster

    Scrobster New Member

    Hi


    My first Droidbox is the T8 v2. I have since also bought the T8-s and T8-s plus. The original box is rarely used as it sits in my winter lounge. It was bought in 2015 and hasn't received a firmware update. I have seen that this can be done and will result in it having a default screen similar to the later models.


    Trouble is, I can't find it anywhere! I have looked through loads of the forums and advice to no avail.

    Can someone point me in the right direction? I'd be happy to get the version that includes the OTA updater as I'm ok using that.


    If I've missed it then I apologise for my short-sightedness!


    Regards


    JB
     
    Last edited: Jan 18, 2017
  2. Nigelar

    Nigelar Well-Known Member

    Hi Scrobster.
    We need to be careful here. Are you certain your "t8 v2" is actually supplied by Droidbox? I ask this because to my knowledge Droidbox have not supplied a box under this precise name although their competitors like Entertainment Box (formerly Droidsticks) have.
    Why is checking this important? Loading firmware not intended for your machine could well break it. So double, triple check before proceeding.

    If your Droidbox t8 was bought prior to July 2015, you have to load the OTA app yourself. A procedure to do that is here.

    https://droidbox.co.uk/blog/droidbox-t8-purchased-before-june-2015/

    Once installed, you should be able to update with all available ota firmware updates.
    If the t8 was bought after July 2015 then ota functionality should work as normal.

    If the box was supplied by Droidsticks, then hop over to their forum (now entertainment box) as they have a similar process for their boxes.

    Hope this helps. If your box is a Droidbox then I can give assurance that the above used to work as I did it on my older t8.
     
    ChrisM likes this.
  3. Scrobster

    Scrobster New Member

    Hi Nigelar
    Thank you for your reply.

    Yes, 100% its a Droidbox as I double checked my Amazon account and I ordered it in March 2015.
    I'm on nights at the moment but will try this on my days off and let you know how I get on.

    Once again, thank you - your time is appreciated!

    Regards
    JB
     
    Nigelar likes this.
  4. Teracir

    Teracir New Member

    I am in same boat and need help, my box says driodbox on top however I dont get the driodbox logo on start up... the screen and setup appear the same.

    The box says t8 v.2.0 at back

    In the information on android it says k200 can you help
     
  5. Dave C

    Dave C Administrator Staff Member

    You can follow the guide at https://www.droidboxforums.com/threads/t8-droidbox-firmware.9763/ to reinstall on T8
     
  6. Teracir

    Teracir New Member

    I have done abit more digging and found the following info under settings:
    model : k200
    android version: 4.4.2
    Build: M8.T8V2.20150516.V3.4.2

    Can you please reconfirm that the firmware update in your link above is till applicable?

    just making sure...
     
  7. Teracir

    Teracir New Member

  8. Nigelar

    Nigelar Well-Known Member

    Android 4.4.2 does not support anything later than kodi 16.
    However, the mygica kodi clone (there used to be a copy in the droidbox market) provides kodi 17 like functionalty.
     
  9. dog with a bone

    dog with a bone New Member

     
  10. dog with a bone

    dog with a bone New Member

    This may be a long reply but may be of help to someone. I have a DroidBox T8 V 2.0 which I have turned into a MX3 4K box. At age 68 I am a novice at this and someone sharper than me may wish to produce a You Tube Video of how to do it. The DroidBox was given to me, I powered it up, got a constant whirling on the home screen, I just didn't like the look of it, and all links looked to be dead. How do I change it. This is where the old adage comes in if you don't know what you are doing leave well alone. Well I didn't. Was booting something up, didn't know what I was doing got stuck in boot mode and turned it off. BRICKED. Started to do some research, opened the box up looked at how to short the pins out on the nand chip, got some sparks, put it back together, still bricked. Did some more reading. Now in the steps I will give you, the more technical of you will understand what I did. Here goes. I got some firmware off this site, put it on a normal SD card in unzipped form and did the reset button power method. I couldn't believe it the box rebooted and I was back in business. I still didn't like the format, and just how easy it was to press a tile and it went back into boot mode and I was back with a brick. Got the SD card out again and got it back working. Did some more reading. Went on the Entertainment Box site they had some fireware. I put it on a SD card in unzipped form and ran it with reset button power method it worked. Everything was blue I didn't like it. Did some more reading. Got the idea that the Droidbox was running S802 with Mali 450. Surely if I get the firmware from another box that has the same guts then it should work. Looked at China Gadgets. Saw that MX3 4K had the same innards, brill tried to download the software, had to jump through so many hoops. Used the USB tool to load the firmware image, got parsing error, just would not work. Loads of questions about this problem, why don't they work, cos the files are corrupt. Now this is where I had some luck. You too will find this I went onto TRONMART . CO and using cut and paste downloaded all the files for the MX3 4K box, no hoops to jump through they came down fast.

    Now loaded up the USB tool, with the 115k4 image, I couldn't believe it, every worked, booted up the box, it was now MX3 4k There is always a problem the remote would not work . Did some more reading, and viewed a video on You Tube about MXQ boxes, after firmware upgrade, remote not working. Something about how to get remote config files. He showed a root tool to do this, of course I downloaded the latest version and couldn't understand how to use it. So I went on the web and downloaded an older version of the software similar to his. Don't waste your time downloading the 4 remote config files that he points to cos they do not work (they are for a different box) I got the remote to work. This is how I did it. I rebooted the Droidbox with it's original firmware, and extracted the remote config file by cutting and paste it to a SD card. Then I rebooted the Tronsmart 115k4 back onto the Droidbox. Using the root tool I extracted the remote config file onto a SD card renaming it, so if I wanted I could put it back. Then I replaced the file with the one from the Droidbox, held my breath booted it up, and hey presto it worked. The original Droidbox remote now works with MX3 4k. I can't say I like the look of the Droidbox remote. So I have been on e-bay and have ordered a MX3 4K remote, I will just put back the tronmart remote config.file. Of course I have loaded Kodi from Mygica media centre 17.1. and everything now works as it should. I hope you can all follow this lot, this was all done by trial and error and by thinking outside the box, I haven't the way with all or brains to produce a You Tube video of how to do all this.
    If there's anybody out there who can do this feel free. It would be nice if you gave me a mention.

    If you lose remote functions when first installing 115k4 you can get by, by using a wireless mouse. Or buying a universal android tv box remote which on the back has a useful keyboard.

    On your original Droidbox if you lost your ability to mount firmware by the reset button /sd card method, if the 115k4 firmware install by usb method works for you, it will give you back the reset button /sd card method. which will give you two strings to your bow. bye
     
    Last edited: Nov 8, 2019
    Dave C likes this.
  11. Ciarence Adams

    Ciarence Adams New Member

    I hate to jack this guys post but where can i get a custom stable rom for the t8s plus 2.0. Please the stock firmware is trash. And yes ive reset and reflashed it.
     
  12. Dave C

    Dave C Administrator Staff Member

    I have replied to you other post with further information.
     
  13. Ciarence Adams

    Ciarence Adams New Member

    Thanx, im able to download the img file now, ill try it and get back to you I dont think its gonna fix the freezing issue though, i just have a feeling
     
  14. dog with a bone

    dog with a bone New Member


    DROIDBOX T8 V2 with S802 inside can now be upgraded to Lollipop 5.1

    Thank you to all at MXQ project. Freaktab and Abdul for supplying twrp files and inspiration. Hard to believe but yes it's true.

    You will need a wireless mouse to navigate within TWRP.

    Here's how . these are basic instructions, but I'm sure you can work through them. Using usb burning tool install Tronsmart MXIII PLUS_102L1_5.1 Beta 1508. There are about 4 variants to go at. The first couple of attempts may fail but it will eventually load, giving you the yellow successful notification. However on reboot you will be stuck on Tronsmart boot loop logo. Don't worry now research Freaktab. Take an SD card format to Fat 32. Go to Abdul's twrp files and get twrp for M8S others may work but this worked on mine. Rename it recovery others say rename it to recovery. img didn't work for me the box never saw it.

    On the same card load matricomboot img available from Freaktab to give myself a chance, cos I don't really know what I'm doing, I put it on in zip form and then expanded it and loaded the img file as well.

    The trick to get 5.1 up and running is the matricomboot image it places all the files that are stuck in boot loop into the right places.

    Now read all the posts in Freaktab. about 5.1 upgrade getting back to the box insert your card, using toothpick method Twrp will come up you will look for the matricomboot image that is going to do all the work, but you won't see it. DON'T GIVE UP. see the post by ivanrandjelovic and Dope 101 follow their instructions about advanced wipe changing cache and data files EXT4 to Fat repairing them and changing them back again. sounds difficult but it's only button pressing and swiping with twrp. When you go back to flash zip, miraculously matricomboot image will appear. look bottom right hand side of screen, press on image, matricomboot image now changes to to 2 items press on boot. 3 items now come up press on boot, flash boot. when finished reboot system. Tronsmart will come up, it will change to a flashing ANDROID then after a couple of minutes you will have 5.1 working on your old box.

    If wifi or your remote does not work, look for another 5.1 rom if you get wifi to work it is easy to pinch remote config files to get your remote to work.

    As my dear old dad used to say Faint heart never won fair lady. I hope I have pointed you in the right direction. GOOD LUCK.

    Update. Best stable rom for me is Tronsmart MXIII Plus_108L1_160604. wifi and ethernet present very stable. as I said to get your remote to work pinch remote config files from your old rom. No doubt this was rooted, now you have upgraded to 5.1 the supersu apk is present but the upgraded rom by default is not rooted, you will have to look at third party apks to do this, the devise will have to be rooted to allow you to delete and drop in new remote config files.

    KingO Root- root apk worked for me, which enabled E.S. file explorer access to the system using these tools I was able to swop config files to get my original Droidbox remote to work with the new operating system. At that I will call it a day.
     
    Last edited: May 13, 2020
Loading...

Share This Page