1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TV BOX H96 MAX X2 does not work after switching off

Discussion in 'H96 MAX X2' started by Rafal W, Feb 5, 2020.

  1. Rafal W

    Rafal W New Member

    Hello
    I have a question for group members and administrators, I have a problem with my TV box.

    TV BOX H96 MAX X2 after turning off the red button on the remote control does not turn on. The red LED on the TV Box lights up. After disconnecting from the power supply, restart, everything works fine, I can restart it from the remote control and everything works fine.
    Please help, maybe someone had such a problem with your box.

    Thank you for the answers and advice, best regards
     
  2. Dave C

    Dave C Administrator Staff Member

    Have you tried a factory reset to see if this resolves the issue. You can do the factory reset from the Settings menu.
     
  3. Rafal W

    Rafal W New Member

    I tried to restore from factory settings and it is the same. I installed new software available for my tv box and it is the same. To start the android box device I have to disconnect the power plug and plug in then it starts up well and everything works.
     
  4. Dave C

    Dave C Administrator Staff Member

    Could you email us at support@droidbox.co.uk with your order number, or the full name and post code the order was sent to and the issue. We can set up a return if in warranty to inspect it. Thanks.
     
Loading...

Share This Page