1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Choppy audio playback on LibreElec

Discussion in 'T8-S Plus' started by patrickyoung, Jan 6, 2017.

  1. patrickyoung

    patrickyoung New Member

    I've recently got LibreElec working on my DroidBOX but find that the audio playback on TV shows and movies is choppy. Every couple of minutes, the audio will cut out and come back. It's a bit of a pain as sometimes you have to guess what's being said on screen. The problem only seems to be on LibreElec. There's no choppy playback when I run the box in Android. Is there something I can do to fix this?
     
  2. ChrisM

    ChrisM Administrator Staff Member

    If you've run a Wizard/installed a build in LibreELEC, my first suggestion would be to use the Fresh Start program add-on, and then install just ONE individual add-on for testing, something that you're using regularly.
    If the audio behaves, I'd then try installing the Wizard/Build. If that causes Audio to misbehave, try this:
    Open File Manager (under the System menu)
    Open the Profile Directory entry
    Highlight the AdvancedSettings.xml file and press C
    Select rename
    Rename the file, anything you like
    Once name has changed, reboot.

    Check if audio back to normal again.
     
  3. patrickyoung

    patrickyoung New Member

    Thanks for getting back to me ChrisM. Before I try the fresh start option in Libreelec can you tell me if that'll wipe everything from the Android side of the box as well?

    Sent from my GT-I9300 using DroidBOX Forums mobile app
     
  4. angela

    angela Well-Known Member

    Hi, In LibreElec go to your program addons and select Fresh Start, if its not there select get more scroll down to find it and install it, run it then reboot your box and you will have a fresh start in LibreElec your android side of the box will stay the same, If you select reset to defaults in LibreElec config then you will most likely lose your android settings as well, so go for the fresh start addon.
     
    sblabs likes this.
  5. StringyMCFC

    StringyMCFC Member

    Hi. I've had the exact same problem myself for a few weeks now on LibreElec. I didn't use a build, I set it all up myself and the problem started seemingly at random, having worked perfectly for some time. I did a fresh start (several times) and installed different addons for testing but the problem remained.

    Similarly to the original post, Android does not suffer the same problem.

    I did a full factory reset of the entire box yesterday so will do some more testing over the next few days. Fingers crossed for a fix to this as it seems like it's not an isolated issue.
     
  6. patrickyoung

    patrickyoung New Member

    I've also tried the fresh start option. It seemed to work for a while but after about half an hour the audio playback started clipping. Is there something different about our boxes?

    Sent from my GT-I9300 using DroidBOX Forums mobile app
     
  7. StringyMCFC

    StringyMCFC Member

    Certainly feels like it. I'm the same in that it works for a while then will get progressively worse with choppy sound. It's almost as though the picture feed and the sound feed get out of sync somehow over the course of the stream and the box resolves it by clipping the sound. The longer it goes on, the worse the sync seems to be.

    No such problems on Android side though.

    Factory reset is complete now and a test addon has been put on. Planning to try it out tomorrow evening so will post back then.

    To clarify, my box is a T8-S Plus with the most recent firmware update (factory reset and OTA update completed on Tuesday afternoon).
     
  8. sblabs

    sblabs Active Member

    i have started using LibreElec so far so good am not getting any issues as mentioned above, will do more testing and report back.
     
    StringyMCFC likes this.
  9. mrbob

    mrbob New Member

    I'm also a relatively new comer to all this stuff and am particularly interested in this issue because I seem to have introduced the problem following a upgrade of firmware. Before absolutely no complaints, after there was a host of 'staggering' video/lip sync issues. The video seems to have been resolved by implementing the hardware accelerator now there is just the very annoying drop of audio, very random, quite frequent and of short duration usually a syllable or word. I'm not aware that I changed anything so I'll interested to see what happens with StringyMCFC
     
  10. patrickyoung

    patrickyoung New Member

    Same here. StringyMCFC can you report back please and let us know how you get on?

    Sent from my GT-I9300 using DroidBOX Forums mobile app
     
  11. StringyMCFC

    StringyMCFC Member

    OK, so a partial update. Following the full factory reset and update the other day I have put a few addons on and just tried to watch a film with my eldest that previously had the stutter problem. The good news is that it hasn't stuttered once. It's only an SD film though so once he is in bed I will put an HD film on for myself and see how that goes on.

    It seems (so far) that the factory reset has worked which makes me think that the idea given by @ChrisM may well work as if it is something that "corrupts" or gets changed for whatever reason in the settings causing the video and audio to lose sync over a period of time, resetting these settings (either by a full factory reset or by renaming the Advanced Settings file as he suggested) seems to do the trick.

    I will watch a HD film shortly and report back. Don't go and do a factory reset just yet!
     
  12. fiveznuff

    fiveznuff Member

  13. StringyMCFC

    StringyMCFC Member

    Just watched a 2 hour HD film and not one stutter or problem with sound.

    My advice would be to do a full factory rest IF you are happy to lose everything (build, settings, other apps on the android side etc). If not, I would give the @ChrisM method a go to see if that works before resorting to a full factory reset.

    I'm fairly confident it's resolved my problems. Good luck!
     
    Nigelar likes this.
  14. sblabs

    sblabs Active Member


    hi mate. no am using the t8s plus, for me libreElec has been rock solid for the past week.
     
    Last edited: Jan 14, 2017
  15. patrickyoung

    patrickyoung New Member

    Bugger. Looks like anyone who's having this choppy playback problem is on their own. I added the advanced settings file to my Android device yesterday but that had no effect whatsoever. I wonder if I should call in a priest to do some sort of exorcism?
     
  16. StringyMCFC

    StringyMCFC Member

    Shame the settings file suggestion didn't work. Have you tried a factory reset? Not a fresh start, a full factory reset?

    Not ideal but it did work for me.
     
  17. David Savage

    David Savage Moderator

    Try these setting see if they help.
    https://droidboxforums.com/posts/29775/
     
  18. patrickyoung

    patrickyoung New Member

    Followed the instructions David and watched the Box for two hours. I can report no choppy playback at all. I think you've cracked it, thanks. Has anyone else tried those instructions posted by David?

    Sent from my GT-I9300 using DroidBOX Forums mobile app
     
    sean99 and David Savage like this.
  19. David Savage

    David Savage Moderator

    Glad it has worked for you.

    Enjoy.
     
  20. Marm

    Marm New Member

    After consistently getting choppy audio after 15 to 20 minutes I tried fresh start but that didn't help. Happy to say that David's solution did!
     
    patrickyoung and David Savage like this.
Loading...

Share This Page