1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sonos

Discussion in 'Beelink GT King' started by Liver_Diver, Feb 17, 2020.

  1. Liver_Diver

    Liver_Diver New Member

    Has any body manged to install Sonos on the GT King. It installs partially but then it asks for permissions but unable to select the slide switch just goes back to disabled, so cant install. Any ideas any body? Thanks Garry
     
  2. Liver_Diver

    Liver_Diver New Member

    OK - Solved my own problem. 1st its a permission issue then a Wifi Issue (fix)
    Ensure Permissions are all set as follows:
    1. Go to setup - the Cogs symbol
    2. Got Droid Settings
    3. More Settings
    4. Apps & Notifications ( Permissions)
    5. Scroll down to App Permissions
    6. Scroll down to Locations
    7. Select the dots (top right hand corner) - and 8. and select show system
    9. Ensure Google Play Services, Google Play Store & Sonos all have the slider to the right (green for permissions)

    That fixes the permissions issue, then:

    10. Go back to installing the Sonos App (re-install if need be) and then you get a different problem (seems common on Android 9 - Pie)
    11. Then carry on installing - it then gets stuck in a loop - ready to install (2nd problem) - Very weird and frustrating
    12. Then go back to main menu - select WiFi on (even on Ethernet) - Obviously put in your correct wireless key password
    13. Go back to installing Sonos and it should complete (weird) - It seems its needs to be wireless to find the speakers (never had to be this before maybe a quirk of Sonos 10.5)
    14. Turn off wireless if on Ethernet (or toggle WiFi Off/On - if on wireless)
    15. All fixed - QED (dont ask me why but it worked for me and a friend who has one of the newer cheaper Droix boxes (but he didn't have the permissions issue just Sonos stuck in a loop when installing)
    16. Thanks to all those that viewed :)
    17. Note Sonos 10.5 now wont work on earlier versions of Android (needs Version 7 or later) - Thanks Sonos (not)
     
    Dave C likes this.
Loading...
Similar Threads - Sonos
  1. fzbob
    Replies:
    22
    Views:
    1,656

Share This Page