1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

unable to play 4k

Discussion in 'T8 Mini' started by PeteA, Aug 5, 2016.

  1. PeteA

    PeteA Member

    Hi Guys
    I hope you can help me out. I received my t8 mini yesterday connected to my 4k tv and all is well untill I try to use any of the Kodi variants, if I have my video resolution set to 4k2k 60 Kodi instantly crashes with a blank screen (not the black screen problem) the only way out is a forced reset of the box via the on/off switch. Also if I try to stream a 4k video (life of pi) using MX player I get no sound and very choppy playback, as if there is no hardware acceleration enabled. All will work fine as soon as I reduce my resolution to 1080p. Tried to use openelec kodi but when set to 4k res the app constantly jumps and is unwatchable. My previous box an MXQ Pro 4k did all of this with no problems at all. So do I have a faulty Box?
    Regards Pete.
     
  2. PeteA

    PeteA Member

    OK guys I have looked into this and it appears that this behavior is normal for Kodi when not on an amlogic device, I.E. display skin etc at 1080p but still outputs 4k video as 4k as the cpu cannot handle decoding a video stream at 4k and display the desktop/skin at 4k. But on an amlogic device the amcodec handles the 4k so everything can be set to 4k and should work. According to Kodi if an amlogic box displays this problem it means that the amcodec is not implemented correctly with the correct permissions! Will this be corrected in a future release of the firmware.
    Regards Pete.
     
  3. PeteA

    PeteA Member

    I have now tried all 4k resolutions with the following results:-
    4k 24 kodi plays but every second or so picture speeds up as if in fast forward then slows to normal.
    4k 25 same as above.
    4k 30 plays but picture very jerky.
    4k 50 displays a very large picture, box locks up kodi crashes on start
    4k 60 same as for 4k 50.
    I am going to return the box as it patently cannot play any form of 4k resolution. Something is not set up correctly on these box's and needs addressing by Droidbox as at the moment they are not performing to advertised spec.

    Regards Pete.
     
  4. Nigelar

    Nigelar Well-Known Member

    Why don't you have a chat with Droidbox first to see if there is anything they can advise? Live chat (see icon on main web page) is available mon - fri. Or you can mail them via the contact us link at bottom of the forum page.
     
  5. PeteA

    PeteA Member

    Hi CordCutterz
    Yes willing to give them a chance to put it right, problem is not sure if it's just my box has a Fault or if it's something wrong with the new s905 processor build. I suspect the latter which means to put it right I will have to wait for a new build of android when tomorrow I can buy a minix neo u1 which will work, and works well.

    Regards Pete.
     
  6. PeteA

    PeteA Member

    OK I have spoken at length with Husham this morning, Husham suspects a timing issue between the t8 and my tv. We found that when the screen goes blank if I pulled the hdmi and reconnected it the screen would come back on and then work as normal @ 4k. Husham is now going to look into this problem back at Droidbox HQ to see if they can replicate and then cure this problem.

    So thanks for your help guys looks like I will be keeping hold of my t8 box after all.

    Regards Pete.
     
    David Savage and Nigelar like this.
  7. Waggers

    Waggers Member

    Sorry to butt into your thread but I received a T8 Mini on Monday and although I have got it connected to my Samsung 4k tv I can only connect at 1080. From your conversation above you seem to be connected at 4k within Android?
    I only have 2 options when I setup my connection in Android or in KODI/Openlec and that is 1080 or 720. I have changed Hdmi ports on the TV and also the cable.
     
  8. PeteA

    PeteA Member

    Hi Waggers
    yes when I open the display app in setup I have all the resolutions, sounds like your tv is not talking to your t8 to let it know what resolutions it can do. Is your HDMI lead marked "high speed" if not you need to get a new HDMI lead. Dont use the one supplied with the t8 as when I was testing mine with Husham we found that it does not support 4k resolution. If this all fails give Husham a ring on the Droidbox.co.uk website tel number (top left) he can log into your box if needs be.
    Regards Pete.
     
    ChrisM likes this.
  9. Waggers

    Waggers Member

    Thanks PeteA
    I was using the supplied cable. My other cables are also the 1.4 versions. This is the first time I have been able to connect a 4k device.
    So off to the Amazon site to get a decent version 2 cable.
    Many thanks for the quick comments.
     
  10. David Savage

    David Savage Moderator

    You need a minimum of HDMI 2.0 cable..plus you don't need to break the bank on one..

    Good luck
     
  11. Waggers

    Waggers Member

    Thanks David - the OA pension won't stretch to a 'posh' one.
     
    David Savage likes this.
  12. PeteA

    PeteA Member

    Hi Waggers
    Can you do me a favour, once you have your t8 mini connected correctly and set to 4k2k 60 resolution can you let me know if you can go direct into Kodi without problems.
    Regards Pete.
     
  13. Waggers

    Waggers Member

    Peter
    Of course - this was your original issue. I hope to get a 'proper' cable tomorrow. I will try Kodi in Android and also the Openlec version (this is my preferred option by the way).
    Regards Glyn.
     
  14. PeteA

    PeteA Member

    Thanks Waggers will be interesting to see what you get, hopefully all will be fine.
    Ps just a thought, in settings did you enable cec, not sure but this may allow your 1.4 cables to work up to 4k2k 30.
    According to their forums the Minix neo u1 has problems if cec is not enabled, also the minix has cec modes 1 and 2 and needs to be set to mode 2 to work correctly at 4k, I wonder if we need this on the Droidbox t8's
    Regards Pete.
     
    Last edited: Aug 10, 2016
  15. Waggers

    Waggers Member

    Yes I did enable CEC as part of my extensive activities to get my cables working. It didn't make any difference to my issue. On my Samsung UE40JU6740 there is only an on/off option for CEC. I have not seen any setting on the T8 for CEC. When I turned CEC on the TV it found the T8 and also my Samsung Blue Ray player. I don't like this feature as it turns on kit if I select a device by accident on the TV. Anyway I will test it off to start with.
    I have just checked the supplied cable and it says high speed on it. However connecting it up I am unable to get 1080 with best rate switch on. I can only get 1080 if I turn the switch off in the T8 setup.
    Anyway just off to get a version 2 cable which pc world says is uhd/4k compatible.
     
  16. Waggers

    Waggers Member

    Well I am not further forward. I have now got a 21gbps version 2 cable and the issue continues where I can only setup 1080 or 720 resolution. I have tried all hdmi ports on the TV and checked the tv manual which states that all 4 ports can support 4k 60.
    I feel I have taken over this thread and not helped PeteA with his issue as originally I was interested in his 4k setup. I am willing to help but until I can configure the T8 to 4k to my TV I can't be of much use.
    I will trigger the remote help and see what that brings unless anybody has more ideas through here.
     
  17. Dave C

    Dave C Administrator Staff Member

    We received your email on our support and are looking into the reported issue. We will update when we have further information. Thanks.
     
  18. ChrisM

    ChrisM Administrator Staff Member

    When you need remote assistance, please come and contact us @Waggers . By the time the e-mail is sent and received (ask for help), you'll likely be on a different screen. https://DroidBOX.co.uk and then start a text chat with us.

    Also, the auto switch option will have to be turned off to select modes manually. It isn't too unusual to find a TV and Android device don't recognize the actual native resolution of the display.
     
  19. Waggers

    Waggers Member

    Hello,
    I don't have Facebook or twitter.
    I have had the auto switch turned off. With it on the T8 defaults to 720 with the option to change to 1080. If I select 1080 the switch turns off as expected. The tv confirms I am in 1080. These are the only 2 resolution options.
    The issue is there are no options on the T8 to select 4k. Out of interest if I force (because it's not shown on the T8 as is not in 4k mode) I search for the 4k channel and then play a 4k video it's fine that is the detail is as good as playing the same video on youtube directly on the smart tv.
    I have tried all hdmi ports on the tv, spoke to Samsung, tried various options in the tv setup etc.
    So what do I do now?
     
  20. ChrisM

    ChrisM Administrator Staff Member

    Facebook/twitter? Lost by that reference there, sorry. In terms of what to do from here, e-mail support continues over the weekend so for this issue at least, probably best to switch to that over the weekend. Regarding a new cable, have we sent you a replacement one yet? If not, please do e-mail us and mention my name (Chris). Let the team know that I've requested they send you a new, confirmed as 2.0, HDMI cable. If you happen to have moved since the device was delivered (!), let them know the new address please.
     
Loading...

Share This Page